Главная Форум Статьи Файлы F.A.Q.


Последние активные темы форума

 
пробуем разобраться с j-link и модемами (134) 18.06.21 14:38 slav
Лаборатория по реанимации (207) 29.05.21 07:58 turon
Huawei E3131 (10) 22.05.21 17:27 mephody13
Флудилка (948) 06.01.21 12:00 Mikhail9977
   
RE: Восстановление модемов с помощью Z_Flasher-Reanimator_modem v-05 «NEW_RAW_RELEASE». ч2 (147) 08.12.20 08:50 palexxx
Модемы Alcatel (177) 04.12.20 15:08 mephody13
Убитые ZTE (442) 02.12.20 10:17 dima83
ZTE Corporation (254) 07.04.20 14:19 mephody13
 

Профиль

   
Логин: Пароль: Забыли пароль?Регистрация


В Линуксе - работа, глюки....
Форум > USB 3G модемы и Пингвин Тукс > В Линуксе - работа, глюки....

Страницы:
Автор Сообщение
 screw
Свердловская обл.
сообщений: 496
#121 Дата 12 дек 2011 22:59
цитата balbes:
Для ZTE 626 скачивал исо-образ для заливки в мопед (разработка бразильцев) в котором есть манагер для Линукса, если правильно помню, там есть несколько вариантов для разных дистров.


Нашел я данный менеджер,но пока,что-то не могу установить.В Линуксе новичок.
 linky
EUA
сообщений: 6
#122 Дата 24 янв 2012 11:57
Подскажите как запустить ZTEMF190 на LInux?
Модем от билайна
Bus 001 Device 004: ID 19d2:2000 ZTE WCDMA Technologies MSM MF627/MF628/MF628+/M
F636+ HSDPA/HSUPA
После переключения через usb_modeswitch
comgt пишет что симка не доступана
dmesg не выдает ничего о подключении новых ttyUSB..
Хотя ls выдает что есть 3 девайса ttyUSB0 1 2 но через pppd тоже не подключает. Может нужно обязательно лок билайна снимать?
Кто как работает, покажите свои скрипты
wvdial выдает что модем не обнаружил.
Какой верный конфиг для usb_modeswitch?

Отредактировано: linky 24 янв 2012 12:44
 SerGGGik
администратор
give-all.biz
сообщений: 1937
#123 Дата 24 янв 2012 18:28
цитата linky:
Может нужно обязательно лок билайна снимать?

Не понял, ты пытаешься с залоченного под билайн выйти с чужой сим?
Это во первых. А во вторых если в форточке он с чужой сим рвет соединение через каждые 2 (10) минут, то в Linux ты не чего не добьешься.
цитата linky:
После переключения через usb_modeswitch

Как я пытался, так там оказывается в разных сборках свои причуды. Далеко не во всех всё одинаково. Опиши конкретно что за сборка и как что запускал по порядку.

Лучше задать 1000 глупых вопросов, чем совершить одну непоправимую глупость!
 linky
EUA
сообщений: 6
#124 Дата 25 янв 2012 07:30
Лок с модема не снимал, все стандартное. Симка билайн
usb_modeswitch попробую собрать последний, пока есть 1,18.
Он переключает модем с 19d2:2000
dmesg выдает 3 ttyUSB. 19d2:0117 Отправляю команду на USB2 отвечает пин ОК, и на вторую home.beeline.ru (что то такое отвечает) Получается работает.
Посмотрел option.ko vid/pid этот есть
Запускаю wvdialconf отвечает нет USB модема. Не могу понять почему?
wvdial 1.60 может еще свежее есть?
 screw
Свердловская обл.
сообщений: 496
#125 Дата 25 янв 2012 17:44
linky,
цитата SerGGGik:
Опиши конкретно что за сборка



 cis
Самара
сообщений: 1195
#126 Дата 26 янв 2012 10:59
Я тоже, осваиваю Ubuntu 11.04,но с модемами никаких проблем не испытываю,все модемы определяются нормально....

Не задавайте мне вопросов, и я не буду вам врать...
 linky
EUA
сообщений: 6
#127 Дата 26 янв 2012 13:53
цитата SerGGGik:
Опиши конкретно что за сборка
Linux 2.6.32 под SH4 платформу.
В ядре есть pppd option.ko usb_modeswitch собирал сам.
Переключаю через usb_modeswitch, находит 3 ttyUSB.
Хочется запустить все через wvdial, но он не находит устройства. Такое впечатление что не верно переходит из сд в модем (может и wvdial кривой)
Какими командами можно опросить модем, что бы понять работает он верно или нет?
 MKAlex
сообщений: 25
#128 Дата 26 янв 2012 23:23
lsusb -v -d xxxx:xxxx
Только не думаю что какая нибудь команда сможет показать что модем работает верно или неверно.
 SerGGGik
администратор
give-all.biz
сообщений: 1937
#129 Дата 27 янв 2012 01:28
цитата linky:
Такое впечатление что не верно переходит из сд в модем (может и wvdial кривой)

Чего-то я вчера это пропустил. Тебе надо его перевести в режим модема. То есть отключить CD-rom. Извиняютсь, я просто упустил из виду что у тебя ZTE (почему-то в голове сидело что у тебя HUAWEI).
Тебе надо в виндосе через любую терминальную программу дать две команды
AT+ZCDRUN=E удаляет файл NODOWNLOAD.FLG
AT+ZCDRUN=8 удаляет файл autorun.flg
А потом уже пробуй в Linux настроить. Но могу сразу огорчить. У меня вот одна сборка KDE стоит. HUAWEI в ней через свой софт автоматически заводятся. А вот с ZTE неделю убил и толку нет. Как и у тебя определяется что вроде есть модем, а дальше модем не отвечает.
Оказалось что в та сборка облегченная и в ней вырезано столько, что всё качать и руками потом настраивать просто смысла нет. Проще было другую версию KDE скачать.

Лучше задать 1000 глупых вопросов, чем совершить одну непоправимую глупость!
 linky
EUA
сообщений: 6
#130 Дата 27 янв 2012 12:51
цитата SerGGGik:
AT+ZCDRUN=E удаляет файл NODOWNLOAD.FLG
AT+ZCDRUN=8 удаляет файл autorun.flg

Вот это я и пытался найти, спасибо за пинок в нужном направлении!!!
Буду копать далее...
Может нужно обязательно снести стандартное ПО от билайн? И залить в модем что то другое ? Где то встречал посты что сносили стандартное и заливали Тайваньское (или как то такое) и именно на нем все стало работать. Хотя может эта смена просто снесла эти файлы autorun.flg NODOWNLOAD.FLG
Страницы:
Перейти на другой форум:
Сайт управляется SiNG cms © 2010-2015