Главная Форум Статьи Файлы F.A.Q.


Последние активные темы форума

 
пробуем разобраться с j-link и модемами (134) 18.06.21 14:38 slav
Лаборатория по реанимации (207) 29.05.21 07:58 turon
Huawei E3131 (10) 22.05.21 17:27 mephody13
Флудилка (948) 06.01.21 12:00 Mikhail9977
   
RE: Восстановление модемов с помощью Z_Flasher-Reanimator_modem v-05 «NEW_RAW_RELEASE». ч2 (147) 08.12.20 08:50 palexxx
Модемы Alcatel (177) 04.12.20 15:08 mephody13
Убитые ZTE (442) 02.12.20 10:17 dima83
ZTE Corporation (254) 07.04.20 14:19 mephody13
 

Профиль

   
Логин: Пароль: Забыли пароль?Регистрация


В Линуксе - работа, глюки....
Форум > USB 3G модемы и Пингвин Тукс > В Линуксе - работа, глюки....

Страницы:
Автор Сообщение
 maverick2005
сообщений: 36
#31 Дата 01 янв 1970 03:00
Написал: spd
Доброго времени суток...

Купил сдуру MF626 от Билайна. Версия прошивки - D_LNP673M3V1.0.102. Неперешиваемая, короче. Соответственно, под Линуксом работает 2 минуты. Насколько я понял, теперь надо в модем засылать что-то более сложное, чем AT+ZOPERTE="beeline". Вопрос к гуру (если уже удалось расковырять процедуру обмена) - есть шанс у линуксоидов? Если удалось, но не будет опубликовано - насколько всё в процедуре обмена запущено, есть смысл самому ковырять?




Смысл ковырять однозначно есть! Сравни логи, надеюсь поймешь ;)


 spd
сообщений:
#32 Дата 01 янв 1970 03:00
Спасибо за логи, попробую разобраться...
 Rafaelvi
сообщений:
#33 Дата 01 янв 1970 03:00
Добрый день. Модем ZTE MF-627 от МТС, с штатной прошивкой. Удалены флаги. При попытке коннекта коннектится и отваливается черех секунд 8
В чем может быть проблема ? Спасибо.
SPOILER
root@ubuntu:etc# pon mts

AT+ZSNT=2,0,0
OK
AT
OK
ATE1
OK
Script usrsbinchat -v -f etcpppchat-usbmodem finished (pid 12413), status = 0x0
Serial connection established.
using channel 13
Using interface ppp0
Connect: ppp0 <--> devttyUS2
sent LCP ConfReq id=0x1
rcvd
sent >
rcvd
rcvd
sent
sent sent
rcvd rcvd rcvd PAP authentication succeeded
sent
rcvd
sent
rcvd
sent
rcvd
sent
rcvd
sent
rcvd
sent
rcvd
sent
rcvd
sent
Modem hangup
Connection terminated.
root@ubuntu:etc#
/SPOILER
 qaz75
сообщений: 40
#34 Дата 01 янв 1970 03:00
А кто чем под линуксом пользуется? Есть симпатичная программка umtsmon (на sourceforge), но у меня она почему-то под убунтой не заработала.
 qaz75
сообщений: 40
#35 Дата 01 янв 1970 03:00
На всякий случай давайте отпишу про свои впечатления. Пробовал два модема: ZTE622 и Huawei 219. Оба, естественно, из-под Билайна, оба изначально незалоченные. В ZTE пришлось сносить флаг, чтобы сразу определялся как модем. Танцы с бубном вокруг usb_modeswitch и перекомпилляция ядра с выключением "мудрой" прескрипции игнорировать такие модемы, как мой, эффекта не дали. Зато после сноса флага все заработало прекрасно. Как уже писал ранее, с umtsmon отношения не сложились (кстати очень советую попробовать - если заработает, то может очень понравиться), так что использую comgt для ввода PIN-а и регистрации в сети плюс wvdial для ввода APN и дозвона. С huawei-ем все заработало еще проще - он сразу определился как модем. С обоими модемами заработала и gnome-ppp, хотя мне больше нравится скриптами. Система ubuntu-8.10, ядро 2.6.27-14



 vanyalgg
сообщений:
#36 Дата 01 янв 1970 03:00
взял от отсюдова>>> http:forum.mdDiscuss.aspx?id=952301&page=1#repl17
сам еще не пробовал подожду новую Ubuntu 9.10 её обещают к октябрю
"
Huawei работает сейчас "из коробки", определяется NetworkManager и запускается Инет без всяких извратов. А вот с ZTE MF 637 не всё, к сожалению, так-же гладко.
Для подключения к Интернету используя этот модем делаем следующее:
SPOILER
1. Подключаем модем ZTE к компьютеру:
- сначала загорается красный цвет на модеме, затем - голубой
2. Вначале модем определяется как CD-ROM.
Поэтому с терминала выполняем : eject sr1 (или как там он у вас определился)
3. По истечении некоторого времени (несколько секунд) индикатор в модеме гаснет, затем загорается красным цветом, далее - голубым. После этого в системе появляется съёмный диск. Тепереь мы уверены, что модем работает в режиме: модема и съёмного диска, однако, система не видит его как модем
4.Чтобы система поняла, что это модем, необходимо с терминала выполнить команду: modprobe usbserial vendor=0x19d2 product=0x0031
5. После этого в системе появятся устройство ttyUS2.
6. Дальше либо рихтуем конфиг nixfloyd для wvdialer-а, либо из-под GUI:
-- Cоздаём новое подключение: Система - Администрирование - Сеть.
-- Выбираем вкладку "Оборудование".
-- Создаём новое оборудование кнопкой "Создать".
-- Выбираем тип аппаратного устройства: "Модем".
-- В устройство модема вписываем: "devttyUS2" (остальное оставить без изменения и нажать "ОК")
-- Выбираем вкладку "Устройства". Далее "Создать", тип соединения: "Модемное соединение", "далее",
-- Номер телефона: *99#
-- Имя провайдера - orange
-- Юзернейм и пароль - ppp
-- Жамкаем "Далее" - "Параметры IP": оставляем как есть, "Далее": "Применить"
-- Нажимаем "Активировать" - "Да" - "Ок"
-- Вы в интернете.

У меня заработало на ура. (Fedora 11 - 2.6.29.6-217.2.3.fc11.i686.PAE SMP)
"/SPOILER
 Masherof
сообщений:
#37 Дата 01 янв 1970 03:00
Если у кого есть инфа, как генерируется код в новой прошивке от пчелайна на MF626, то я готов написать софт(скрипт) под Linux.
P.S. Сам в этом заинтересован.
 qaz75
сообщений: 40
#38 Дата 01 янв 1970 03:00
Написал: vanyalgg
У меня заработало на ура. (Fedora 11 - 2.6.29.6-217.2.3.fc11.i686.PAE SMP)



А какие есть варианты вводить PIN-код? Можно, конечно, отключить. А если нет, то знаю только comgt, который умеет его запрашивать. Ну и уже рекламированный мной umtsmon. :) Ужасно обидно, что он у меня так и не заработал нормально ни с одним из модемов. Одна из старых версий (0.9) писала ошибку в pppd, но соединение устанавливала. Новые версии выдают ошибку и все. Интересно, это проблема с дистрибутивом?
 vanyalgg
сообщений:
#39 Дата 01 янв 1970 03:00
Написал: qaz75
Написал: vanyalgg
У меня заработало на ура. (Fedora 11 - 2.6.29.6-217.2.3.fc11.i686.PAE SMP)



А какие есть варианты вводить PIN-код? Можно, конечно, отключить. А если нет, то знаю только comgt, который умеет его запрашивать. Ну и уже рекламированный мной umtsmon. :) Ужасно обидно, что он у меня так и не заработал нормально ни с одним из модемов. Одна из старых версий (0.9) писала ошибку в pppd, но соединение устанавливала. Новые версии выдают ошибку и все. Интересно, это проблема с дистрибутивом?



Я сам это всё не делал .Пробовал с убунтой 8.10 повозился час бросил подожду 9.10 убунту .
Я считаю что если в Убунте не заводиться нигде не заведется надо ждать новых версий дистрибутивов где в кернеле или еще где зальют поддержку ZTE модемов
Mac OS вроде таже FreeSD с красивой оболочкой ... И все ZTE модемы вроде работают с MAC OS X . Интересно кто нибудь пробовал запускать ZTEешки из под FreeSD ?
 spd
сообщений:
#40 Дата 01 янв 1970 03:00
Написал: Masherof
Ок. Изначально я планирую сделать вариант для DIR-320 на прошивке Olega. Там линь на ядре 2.4



Да это, по-большому счету, непринципиально. Там в этом алгоритме, насколько я понял, только операции логического сложения, умножения и сдвига. Главное, знать в какой порт модема из трех засылать ответ и важны ли таймауты.

PS . Инфу прислали? Если нет, то у меня есть файл Maverika...
Страницы:
Перейти на другой форум:
Сайт управляется SiNG cms © 2010-2015